This project has moved and is read-only. For the latest updates, please go here.

Unable to fill a field in a survey

Nov 17, 2015 at 4:46 PM

I've downloaded and uploaded all the files and created a CEWP referencing an html file on my survey page on a Sharepoint Online site. Currently, I'm just using a slightly amended 'hello world' script to populate a field called ContractID with a text string of 'C42', however, when I load the page nothing happens.

When I run it through the debugger I get the following message:

SCRIPT5022: Error creating field named ContractID: getSPFieldType error: TypeError: Unable to get property 'childNodes' of undefined or null reference

I've tried changing permissions, changing the field name but no matter what I do the message still appears. Can anyone help?

Thanks in anticipation.

Nov 17, 2015 at 5:32 PM
I'll take a look and let you know.
Nov 25, 2015 at 9:22 PM
Sorry for the delay. I can confirm this is an issue in SharePoint 2013 was able to repro it in my environment. I also logged an issue here: